Bot Not Showing Under 'Specific Robot'

Hi guys,

I feel like I must be going crazy because I’ve done this a billion times at various clients, but right now I can’t seem to get it to work on Orchestrator CE and my personal laptop.

I have created a simple automation containing a single Log Message activity and am attempting to publish this and then start / run it as a job from Orchestrator. When I click “Start Job”, however, my bot does not appear in the “Specific robots” list.

If I select “Allocate dynamically” and run the process it will sit in a “Pending” status indefinitely.

Before anyone points me to any of the numerous similarly-titled posts here on the forum, please take a careful look at the screenshots I’ve included below. I have read up on a couple dozen other forum posts myself, and most the time peoples’ issue has been that they failed to setup / connect an environment or machine appropriately. I have triple-checked all my environment / bot / machine settings (see below) and everything seems to be in order. (I have also deleted everything and started from scratch twice now just to be sure, but no luck.)

Note that something else weird is that UiPath Attendant on my machine shows that I am connected to Orchestrator, but Orchestrator (on the Robots page) does not recognize that my machine is connected.

I doubt this is related, but one last thing I’ve noticed is that my process is being labeled by default as “Requires Human Interaction”, even though as I previously mentioned the only thing it contains is a single Log Message activity. I tried updating the corresponding flag in the project.json file and republishing to see if this would make any difference. It did get rid of the “Requires Human Interaction” icon (replacing it with a “Background automation” icon), but it did not fix the issue with my bot not showing in the “Specific robots” list when I go to run the job.

I have spent way too long trying to figure this out on my own and am even wondering if there is just something messed up with Orchestrator CE right now. Any help would be appreciated!


My initial guess is you may need to try updating your Machine Name. I’ve always used the same machine name as whatever machine I have the robot installed (which is also what UiPath indicates you should do).

Right now you are using “My Machine”, and it looks like your actual machine name is “LAPTOP-4GBPKSLD”.

Your friend,


Hey Marty!

Thank you so much!! I see your Robot Master skillz are sharp as ever. :slight_smile:

That was 100% my issue and everything is working fine now. Knew I must’ve been forgetting something obvious… Oops! :woozy_face:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.