Body of activity HttpRequest

When I run my request through postman it works .


When I pass json string of body in HttpRequest body and set body format as application/json, it does not work

The json string is as below:
“{‘start_time’:{‘timestamp’: ‘1634860800’},‘end_time’:{‘timestamp’: ‘1634868000’}}”

I could not figure it out. Please anyone can help me .Thanks a lot !

grafik
give a try on using double quotes for escaping quotes within a string

Thank you! But I tried with double quotes as below also ,still get error response.
“{”“start_time”": { ““timestamp””: ““1634860800"”},”“end_time”": {"“timestamp”": ““1634868000"”}}”

please show us on how it was implemented and used. maybe you share some more details e.g. by screenshot. Thanks

we would also recommend letting the timestamp value without sourrounding " " and passing it as digit value

These are screenshot of postman(body ,header,param)
image


This is uipath activity:

image

image


The string I set is:
“{”“start_time”": { ““timestamp””: ““1634860800"”},”“end_time”": {"“timestamp”": ““1634868000"”}}”

check the postman screenshot here you are passing the timestamp as number. Just check by doing the same

grafik

"{""start_time"":{""timestamp"": 1634860800},""end_time"":{""timestamp"": 1634868000}}"

1 Like

passing the timestamp as number ,we get the same error msg