Attaching to Chromium API protocol failed. To use Chromium API on this page, please close any extension pop-up using a different input method

Attaching to Chromium API protocol failed. To use Chromium API on this page, please close any extension pop-up using a different input method.

Hi @guptavarsha1,

Can you try re-enabling the extension?

Thanks,
Ashwini Kempraj

hi,

can you try changin the input mode in your use application/browser activity?

use simulate or hardware events,

Regards!

2 Likes

Can you provide a short recording / screenshot of the target app while the error is thrown?

PFA the application screenshot.

The issue occurred when i was trying to login and credentials were already saved to google. I got Key symbol next to username text box and then the error was thrown in studio.

Hardware events mode worked for me. But can you tell me the reason behind it because for others it worked same “Chromium API” same use case.

1 Like

What is that Key near the Email field? Is that a Chrome extension?

After further research, I think that is a Kaspersky extension for password management. The bad part is that it renders stuff on the page, inside an iframe, that is not accessible from our extension. There is a specific check inside the Chromium code that forbids attaching the debugger in these types of situations. The solutions are to use a different input method or to disable the extension for this page / browser.

1 Like

great, you can check this nice tutorial

also you can try attaching your webpage in another use app/browser activity and then maping your selector again.

if it helps remember to close the topic and mark as solution

Regards!

I ran in to this problem today and found that it was a conflict between UiPath extension and the LastPass extension. As soon as I turned off LastPass, the problem disappeared. It may also conflict with other extensions.

I think it’s safe to assume the issue is LastPass was trying to use a different input method.

5 Likes


I have tried everything and now this is a new error

Nice, this fixed it for me because I had LastPass enabled. Thank you sir

2 Likes

How do you turn off LassPass?

@Tschultz

Browse to chrome://extensions/ and then look for and click the switch to turn it off.

Try turning off all extensions first, then start by enabling the UiPath Browser Extension before enabling any other extensions afterward.