Assistant Unexpected Exit Code - 0xE0434352

I am a developer trying to install a stand-alone attended package on a user’s Assistant (v2021.18)

We can get the package installed, but when trying to run it from Assistant, it gives a “Job stopped with an unexpected exit code: 0xE0434352.”

After some searching it looks like that exit code is related to Excel. However, even when I give the user with a test process that just prints “Hello World” and doesn’t have the Excel package installed, it still throws that exact same exit code.

Something we noticed is that in the user’s add-ins, the UiPath Excel Add-In is showing the following error: “Excel version - 16.0,System.NullReferenceException: Object reference not set to an instance of an object.” The user does have Excel installed on their machine

What we have tried:

  • Uninstalling and re-installing UiPath Assistant on user’s machine
  • Updating Excel package to latest dependency in the process we’re trying to run (2.22.2)
  • Running a separate process that works perfectly on a different user’s machine. In the first screenshot below, see the “Norcross.Tiered.Rates” process error - this is the same package that works on another user’s machine (same UiPath Assistant version)
  • Running a test process with no Excel packages (quits with same exit code)
  • Checking user’s Event Viewer (user doesn’t have access to view application/event logs)

Any help would be much appreciated!!

Here is a screenshot of the UiPath_ExcelAddIn error

Hi @Welk_Angela

Welcome to Community!!

Please check on this

Hope this helps!!

Hey, @Welk_Angela
Can you please confirm if the solution above worked? :hugs:

Hi Irtelala and Ianus,

I did see that Community Forum post, however we have tried that solution and unfortunately it does not work. I can’t even get to the point in the automation where the user selects the Excel file they are using because the job doesn’t start to get that far.

Check this troubleshooting guide