Are there any plans to make Robot for ARM architecture?

This year we saw introduction of unattended robots running in Linux containers. Are there any plans to make Robot running on Linux for ARM architecture?

Hi @mateuszmacheta,

May be may be not.

The use case is so limited. Other than a novetly point that UiPath robots can run on a Raspberry Pi, I do not se them being used as a replacement to battle tested version of UiPath robots on x86 platform.

But I too would like to see the robot being able to run on docker on a Raspberry Pi at least for us community users. Raspberry Pi running cross platform project. How cool would that be!

I did post a question on this when the docker container for Linux automation was launched.

May be @erghe knows more about roadmap.

1 Like

Thanks for reply @jeevith, that’s exactly what I wanted to do: run robot on Raspberry Pi. I found this article that gave me hope - Run AMD64 Docker Images On An ARM Computer but sadly it did not work.If I was more experienced with docker then at least I would know if there’s anything more I can do, but right now I just now I’m getting some errors and not sure how to proceed.

Maybe I’ll try again what I was falling back to - finding some RPA tool that would work on Pi. But having UiPath bot there would be awesome, as I would not have to learn anything just to make a couple of simple bots for my personal use :slight_smile:

I have managed to install Windows 11 (ARM Version) on Rasbperry PI, but right now after connecting to Orchestrator I’m getting below error:

Connected to Orchestrator. Unable to retrieve a license (please contact your IT department)

I have one Unattended license from community edition.

Edit:
I have even created new Orchestartor instance and I got the same error. Finally I got rid of it by using interactive login. Interestingly, after I clicked Sign In in UiPath Assistant, it did not work, but started working I think after restarting UiPath services. Still not able to run some basic Chrome automation, but will continue debugging this.

Edit 2:
I finally managed to run simple Hello, World! program on Raspberry Pi 4B / 8 GB with Windows 11. Though it took around 5 minutes before starting job in the Orchestrator to actually going through the activities. I have not yet run successfull GUI automation which is why I started the whole project.

1 Like