Append range is not working

Hi,
I tried all possible ways to append range but it’s not working

I have 4 tables coming from read range activities that I want to append in one sheet

Can you please help me

Why the append range is not working I am using it by the book

Hi

Does all the table have same set of column and is column order same across them

And instead of writing it to excel directly give a try with merge datatable activity where mention the source dt and destination dt

Repeat the same for all and then write the destination dt to excel with WRITE RANGE activity from workbook activities instead of excel

Pls share us the error screenshot as well

Cheers @HKF

@HKF

What’s the issue you are getting?

It will be good to provide some screenshots to understand the issue

Thanks

I tried merged tables first
It didn’t work
That’s why I am doing append but it’s not working
The thing it dosnt give me error
But it jusg wont do it

I have the same set
The column names are the same
All suppose to be good

Is there any open source to merge four tables together?

Try with APPEND RANGE under workbook activities instead of excel

and to just validate before writing to excel with append range use a writeline activity and mentin like this
yourdatatablevariablename.Rows.Count.ToString

make sure that value is more than 0

or can we have your workflow so that we will see what is missing

Cheers @HKF

Hi @HKF ,

If append doesn’t work for you then you can also try below approach.

Steps:
1 - Read main excel where you want to paste other excel
Get count of main data table and to + 2 accordingly if header starts from row 1
ex - lastRow = dtMain.Rows.Count + 2
2 - Use Write Range activity and pass last row to cell and also pass data table of first excel.
Similar way you can repeat this step for other excels.

Thanks for your reply
It worked

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.