Add log fields activity not working

The property “Fields” in the activity “Add log fields” is greyed out.
Not allowing me add data.
Does it have anything to do with me working on a library?
Is it only supposed to work with a process?

AddLogFields

Any help would be appreciated.

Project Dependencies:

  • UiPath.System.Activities 23.10.2
  • UiPath.UIAutomation.Activities 23.10.3

Hello @Rui_Leite

  1. Activity Context: Ensure it’s used within a valid sequence or workflow.
  2. Activity Placement: Confirm it’s placed correctly within a supported container.
  3. Activity Version: Check compatibility between the activity version and UiPath Studio.
  4. Restart Studio: Try restarting UiPath Studio to resolve minor issues.

Thanks & Cheers!!!

I’m trying to use add log fields to combine a series of input arguments into a single log message, instead of sending several stand alone log messages.

The sequence in which the add log fields activity is placed is valid.

The error reported by the activity is “Please provide at least one field” but i can’t because the field is greyed out.

I have restarted Studio as suggested, ending with the same result.

Is there a new container for this type of activity?

Hi @Rui_Leite

Use the modern Add Log Field activity

Cheers!

Hello, @Dinesh_Guptil

Can you show me your project dependencies?
I have activated the modern experience in the project settings yet the “new” activity does not show up in the activities panel.

I checked the filters and they seem fine.

@Rui_Leite

Please Check

@Dinesh_Guptil

I matched your dependencies (with some slight changes due to package version) and it still doesn’t show up

Log

Can you hover on the activity name, like I did in this screenshot ?

Log2

Hi @Rui_Leite

Your are using the legacy process make sure you use the modern process

I believe I’m using the modern experience.
I am using other activities found only in the modern experience.


Could you post a screenshot of all dependencies for your project?

@Rui_Leite
Please check this

@efelantti

Dependencies

@Dinesh_Guptil

image

@Rui_Leite

Disable show classic option

Same result.
It only show one result.

@Rui_Leite

Make sure you are using windows file not the legacy one

@Rui_Leite

even in legacy the activity is allowing to add collection
delete the activity and pull it again

How can i check that?

@Rui_Leite

at the bottom it will show whether it is windows or windows legacy

image