"access to path is denied" - when running the bot on Orchestrator

Hello guys,

I have a bot that reads a csv file. The file path it fetches via Orchestrator Asset.
It works fine, when I run it locally.

Now i published the bot on our orchestrator and set up a process. When I run the process now with the same robot account unattended I always receive the error “access to path is denied” on that specific csv (it also includes the path from the asset so it fetches it correctly).

The csv file is in no way shape or form open and the robot has full rights to this file when I try it manually. I only get this error when I run the robot unattended using orchestrator.

What could possible solutions be?

Thank you very much.

@GeraltDieSocke

Are you able to run the process from UiPath Assistant in that Robot machine ?

If yes and it’s working fine then check whether you passed same account details while creating Unattended Robot. If you have any shared path then place file inside that shared folder and read it from there instead of changing the path in Orchestrator Assets everytime.

@lakshman

Hi, thx for the good suggestion. I tried running it with UIPath assistant on that machine and that worked.

I don’t understand your second point. I don’t change the asset at all. It’s a static path I fetch from orchestrator, so the customer can customize this path in the future if necessary.

Why is it working with UIPath Assistent and not over Orchestrator? I double checked the user. I also receive the error from the same robot account (the robot account is in the error message).

Thx very much

@GeraltDieSocke

Can you please share screenshot of the folder path you are passing in Orchestrator Assets.

@lakshman

Sure enough:

As I was posting this I was thinking. This process I marked as “runs in background” robot in UIPath Studio. Maybe thats the problem? Because I have a second robot that also reads and writes to this csv file and that just worked fine over Orchestrator and this robot is not marked as “runs in background”.

Might this the problem?

Thank you

Is your unattended robot that is failing operating from a different server with a different active directory or service account credentials than the first one? Not sure how you have your architecture set up. If so, your second robot may not have rights in Active Directory to this path.

I can confirm. The problem was that I set the process to “process runs in background”. That won’t work since it will never authenticate on the machine, and the file is on a share with permissions, so the robot has to be authenticated.

Solution: Disable “Process runs in background”. Now it works :slight_smile:
Thx for all your help

For some context of why this is, have a read over the following documentation

Starting with the 2021.10 release, running unattended background automations on service-mode robots run by default under the built-in "Local Service” Windows user. Prior to this, the username and password configured for the robot in Orchestrator were used.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.