Generate yearly report: Problem reading .csv files

Dear Friends,

I am having problem with assignment 2 at Performer section: Everytime it tries to read the downloaded .CSV files, it gives error message indicating that the programme does not have access to go to the folder:

Cannot access file path, access is denied :


have tried anything:

  • start the programme as administrator
  • Uninstall and reinstall the programme
  • Use Administrator account and run the programme from there

Nothing works. What I notice is that my Robot execution file stated in Windows Services and running, but the robot does not appear in the tray until I call it from the local app folder. Could this be the reason that the programme cannot run the script? if yes, do you have the solution?
Thank you for sharing with me!

Hi @Nazarius,
I don’t think the issue is because Robot in Local app folder. If this is the issue, it should not work for any project but not only the .csv files.

May be , you can try by changing the location of files .csv that you save and read.

Regards,
SP

Hi SP,

Thank you for your response. I changed the path in config to my desktop. However, the same nightmare comes again: access to path is again denied. Help please, what do I need to change? I change the password in the orchestrator Robot the same like my windows account: nix, nada … no progress…:frowning:

Share your workflow or screenshot

Hi Prankurjoshi,

Please see hereunder my XAML data. I have done everything but the issue still persists. Can you please help? THanks a lot
System1_CreateYearlyReport.xaml…xaml (33.8 KB)

i also have the same problem :frowning: can anyone who knows to answer this?

Guys ,
I am also facing this issue. When the Bot saves the file, the files are saved.Neither the bot nor I can go and delete the files. “Access denied issue” comes over. However, when I restart the machine, the files which I tried deleting earlier vanish.
Solutions Tried:
I tried checking if there are muktiple version of Uipath running on the machine. But, did not see anything like that.only 2019.2 is installed.
@alexandru - Can you please help.

Was there ever a solution for this?
I am facing the same issue, so is others i different threads. But no solutions found to get around the problem.

Hi all,

This issue was solved a long time ago, unfortunately I forgot what was the action I took to solve it.
I only remember something with the datapath itself. Firstly I introduced the path folder instead of the file path itself (if I remembered it correctly). Then I reassigned the path value and it worked.
Hope this helps. Cheers!

1 Like