Access to path is denied after update 2021.6.0-beta.4541 - All activities

Hi,

Today after an update of Community Edition Studio, all activities that require rights to create/move/delete/edit any files stopped working and throw Access to the path is denied System.UnauthorizedAccessException.

This includes any create, move, delete file, excel scope activities, write csv or text file and basically any such activity. Before the update everything was working fine. Any idea what might have caused it?

I tried to restart the computer and reinstall UiPath but the problem persists.

@Jan_Kucera

Have a look below thread.

The robot is running on my administrator account so the access rights should not be the issue.

Nevermind, fixed it :slight_smile:

@Jan_Kucera

Great.

Can you please post solution you tried to fix this issue. It will help other users who are facing similar kind of issue. Thanks.

Ok, I take back what I said. I’m not sure what I did yesterday but it worked once. Today I have the same problem, anywhere on the C drive I try to create a file I get the error.

ok, I added UiPath Executor into the allowed apps of Avast antivirus and it seems to be working for now, so the antivirus was blocking the app from accessing any files.

1 Like

Thanks @Jan_Kucera

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.