(413) Request Entity Too Large

orchestrator

#1

413 Error

We are getting “(413) Request Entity Too Large…” error when trying to publish workflows with subroutines. The overall solution is not very large. XAML files are less than 400K and .screenshots is less than .800K. Any help would be greatly appreciated. We are stuck trying to get production up and running.

NOTE: Version 2016.2.6274

Thank you.


#2

Note that Publish will basically zip everything from the main project folder into the nupkg. Check if there aren’t any forgotten large files somewhere.

Alternatively, disconnect from the Orchestrator for a while, publish locally and check package size. If it’s as you’d expect (~1,2MB), I’d file a support ticket as something is off. If it’s much bigger, unzip it and check what it grabbed.


#3

We are able to publish this to production without any errors. The problem is only happening in the test environment. Ticket is open…


#4

We are having the same problem on 2018.1.1 on premise.
Two packages (868 + 1823Kb package size) cannot be published via Studio. However, if we publish them locally and upload to ORCH via the admin module there is no problem. Another test: package consisting of small workflow + huge zip file failed. If the zip file is removed the package publishes nicely.
Strangely enough, the same packages worked 100% on ORCH 2017.SP1.1 - same packages, same tenants, same network etc.
It looks like a size limitation has been activated since the last ORCH version.
I’ve tried to fiddle with the Deaployment URL but so far haven’t found the right setting.
BR
/Klaus


#5

Additional info (perhaps helpful): one of my developers has informed me that: the Studio on th developer’s machine is regietered as NonProduction in ORCH. This also prevents using Debug mode. Maybe it’s a license issue.
BR
/Klaus


Issue with Packages in Orchestrator
#6

As it turned out, It is a problem with IIS and the size of packages it will receive.
I might have misread the paragraph in UiPath Docs about setting it to a higher value. There are two values that should be altered. Go to IIS Admin and selecte the ORCH web site. Then open Configuration Editor and find the following section:

system.webServer/serverRuntime
maxRequestEntityAllowed = 4294967295 (4Gb, max value)
uploadReadAheadSize = 2147483648 (2Gb)

Reset IIS and voila :slight_smile:

Best regards
/Klaus