Write Cell not working with the following string "=VLOOKUP(D2,Sheet2!A2:N$24,14,0)"

The result at the Excel file is a “#NAME?” error.

The wired thing is the following. At Excel, at the edit-formula text box, I cut the text “Sheet2” and then paste it at the same place within the string, hit enter, and the error is gone, and the formula produces the expected result.

Please help.

@oscar.lepe Try like below.


Hi, thanks. I did, but the result is the same.

Curious thing is that, after the robot is finished, and I open manually the Excel file, the two ’ do not show at Excel. If a manually insert the two ', then the formula produces it expected result.

Any other thoughts?

@oscar.lepe Open and close excel and open again after doing uipath execution and it might work. if it doesn’t upload sample excel file, i will try

Thanks @Manjuts90. Still doesn’t work, here the sample excel file. At sheet VL06O, cells E2:E100 have the formula typed by the robot. The cell shows the NAME? error.

consolidado.xlsx (26.4 KB)

@oscar.lepe try below workflow it working fine.

expNew.xaml (8.9 KB)

1 Like

Thanks @Manjuts90, it worked.

Thanks to your input, I found that even though my Excel installation is in Spanish, the interaction between UiPath and Excel has to be in English.

I changed my original workflow to write-cell with a string having the name of the formula in English and it also worked.

In any case, I like better your workflow, because I wasn’t calculating the length of the table, and you did. It’s better. Thanks again.


@oscar.lepe Ur welcome bro :grinning:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.