Windows framework type package is recognized as Windows-Legacy in orchestrator

Hi Team,

I developed the code by creating the project with Windows framework compatibility and created a local package. The folder structure in the local package seem to look good. Please note that the package will be published to the local folder using Studio and is then pushed to orchestrator through Jenkins job

However when the package been pushed to orchestrator, it is recognized as Windows-Legacy. When I try to run in a robot machine, it fails with the error as "Could not find a part of the path 'C:\Users<Username>.nuget\packages<project folder><version folder>\lib\net45\project.json

Studio version (Developed) - 21.10.7
Studio version (Package published) - 22.10.7
Orchestrator version - 22.10.3

Please help to resolve the issue.


Welcome to forums

When you opening a legacy project in new studio, did you get a warning to convert that in to Windows?


Hi @Srini84 ,

When it is a legacy project, I am getting a warning to convert that to Windows in Studio. However, the project I have issue with was created as Windows type itself and not a converted one.

@andreiT / @loginerror - Any ideas please… Please also tag other people you know who might have some potential workarounds/solutions


May be publishing it though jenkins is creating the problem…for now can you try uploading the package manually or directly publish to orchestrator and check if it published properly


Its issue with the jenkins pipeline which is publishing it to orch, did you start using Windows recently and earlier using legacy ?


Yes, we tried uploading the package manually and it works. For which we changed the orchestrator settings and tried. However we cant retain the same settings due to the policy


We just started using Windows for new projects and were using legacy earlier. We figured out that the Jenkins pipeline is causing the trouble. Any idea/suggestions on what could be causing the trouble exactly and any solution we have?

The Jenkins job actually pushes the package to an external artifactory and the orchestrator uses that artifactory as the external feed for the pacakges


Ideally I believe while building the project …it is failing to build as a windoes project… better to verify the configuration there…as deploy task is only to upload the package and the nupkg is formed in the build itself


Could you verify Project.json once and see if it says Windows there, also from external artefactory verify the project( Convert and unzip if you have to) and then check json file details if you see any difference.


I have verified the built package and it looks fine. If I directly upload the package to orchestrator and run , it works without any issue and gets recognised as windows project properly.

The issue happens when we push the package to external artifactory and reference that using external feed option in orchestrator


Yes, we verified by unzipping the nuget packages created in local as well as the package from the artifactory. They looks good and we tried uploading manually both (the one published to local folder and the one downloaded from artifactory) and they are recognised as Windows type and it’s running fine