User cannot execute bot

Hi,
One of my bot users is encountering an issue that I have no knowledge of. Somehow, the installed RPA path seems to be corrupted as seen in the screenshot attached. The other user does not have this issue and the bot runs fine on that machine. How can I support this user who has this issue?

Hello @dari_donkuro

Please check the below.

https://forum.uipath.com/t/could-not-load-file-or-assembly-uipath-interop/307215

Thanks,
Jesh

Hi

  1. Delete the Project.Json file from your project
  2. Go to this folder %ProgramFiles%\UiPath\Studio\Packages and delete the image highlighted packages

image

  1. Then open the Main.xaml and project dependencies will load automatically and nee project Json file will get created

Cheers @dari_donkuro

1 Like

Thank very much for your response. This on customer’s end and I need to produce a guide document for IT Team to execute, so, I want confirm what I understand from your response.

  1. Need to delete project.json from workflow
  2. Delete uipath.terminal.activities.2.3.0.nupkg & microsoft.xaml.behaviors.wpf.1.1.31.nupkg from C:\Program Files (x86)\UiPath\Studio\Packages
  3. Afterwards, launch UiPath studio and open the main workflow. This will fix issue. Is that correct? Note: The directory location is C:\Program Files (x86)\UiPath\Studio\Packages in on our setup.
1 Like

That’s correct. However suggest you to give 2 options for the troubleshoot.

Though before documenting, make sure you try it for at least one user as a troubleshoot to confirm, if possible.

That user is using studio, then first troubleshoot step should be to check the feed settings, are all the required fees source selected? Official,. nuget, orchestrator host, etc

Terminal activity often show this behavior of not updated correctly.

No worries

Please mention the steps like this in your document

  1. Open main xaml and in design panel → Manage packages → Settings and check whether all feeds are enabled
    If not enable it

  2. Then close the studio

  3. Open the project folder and take a backup of Project.Json file and then delete that file from the project folder

  4. Delete uipath.terminal.activities.2.3.0.nupkg & microsoft.xaml.behaviors.wpf.1.1.31.nupkg from C:\Program Files (x86)\UiPath\Studio\Packages

  5. Afterwards, launch UiPath studio and open the main workflow.

Hope this would help you resolve this

Cheers @dari_donkuro

1 Like

Hello,
I was out of office last week and now getting back on this issue. I followed these steps partially in my development environment while I am writting the troubleshooting document, but I realized that after renaming the project.json (step #3), I was not able to open the workflow anymore (step #5). Instead, the project was removed from the recent open project list, but a new project.json was not created.
I was not able to delete the two packages because I do not have admin privileges to modify the directory. Did this happen because the packages were not deleted? If this happens even after deleting the packages by IT personnel, then I will be lost. When I changed back to project.json, I was able to open the wokflow again.

Do you mean rename or delete

We need to delete the project.Json file
And once after deleting if we open the main xaml new project Json will get created automatically as studio loads the dependencies freshly and generate that Json file

Well in that case
-First open the file in studio and click on project panel and remove those two dependencies by right clicking on the package name in project panel

-then save and close the studio and then try deleting project Json file and reopen main xaml

@dari_donkuro

This user probably can’t access myget.org (the official package repository).

You can just copy those packages from the machine where it works to the machine where it doesn’t, or upload the packages into Orchestrator so they’re available to all attended users.