Use existing Azure Enterprise App Registration in Integration Service for Office365


Currently our Azure Portal is limited by our company policy and normal users are not allowed to add apps in Azure. Our administrators prefer to have control over the Registered Enterprise Apps and permissions granted in Azure.

For the classic Microsoft Office 365 activities (the old ones placed under a Scope parent activity) we defined our own Enterprise Application in Azure and we worked together with the Administrators to configure the App by granting the necessary scope permissions, following this guide, and everything works fine.

However, now we would like to take advantage of the event triggers, which are available only in the Integration Service, but it seems that the connection with the Integration Services enforces us another Azure App

I have read the documentation on the Microsoft connector, but doesn’t say much. For instance, the statement: NOTE: Please work with your IT team to allow these privileges for your user and application. doesn’t specify if we can use an existing application, defined by us with the scope mentioned or if only the Azure App enforced by Integration Service can be used.

This is the error that appear when trying to connect, because of the limitation. Will be possible in the future to specify an existing Application ID + Tenany ID in the Integration Service connections?


I know that an easy way would be to invite an Azure Administrator and approve everything, but we would prefer to use the Apps that we defined already for the old Office365 activities.

We also require using a provided App registration (App ID / Client ID) for the Sharepoint integration.

I understand we can use the UiPath Sharepoint activity package but not with the integration.

Here is o365 I belive we could use an article on setting up App ID / Client ID for Sharepoint:


Last week a new update came into my Orchestrator cloud and it is possible to provide a custom App Id for the Integration Services:

When I try this method with a completely new app registration, it goes through the point of asking for organization permission (which I grant) and then it throws an error saying the scret provided does not match the app. WHich I can confirm 500% it does, I have tried it 4 times using the exact app registration from microsoft and the app secret

Make sure to use the secret value, and not the id

Also make sure to allow accounts in any organizational directory:

Correct I am using the Value not ID, and then the supported account types is the broadest like you indicated.

After trying about 10 times, it finally took, trying over and over and over again with the same values… seems like a bug