Unable to start job via API

Hello peoples!

I am trying to start a job via API on the cloud orchestrator.
This is my data component in the POST requests:

start_data = {“startInfo”:
{
“ReleaseKey”: “ae52ada4-ac4e-4823-9594-a0c286b1b8f1”,
“Strategy”: “Specific”,
“RobotIds”: [ 3588 ],
“JobsCount”: 0,
“Source”: “Manual”,
}
}

And my header is:

start_header = {“Authorization”: bearer, “X-UIPATH-TenantName”: tenant_name, “X-UIPATH-Organization”: “2061”}

However I receive this response
“{“message”:“startJobParameters must not be null”,“errorCode”:0,“resourceIds”:null}”
I have no idea what I am doing wrong, I’ve looked here: https://postman.uipath.rocks/?version=latest#2715a573-80d0-4a85-be22-a5d637e4c5fb and here: Jobs Requests

But I cannot find what I am doing wrong?

Hi!
did you solve the problem? I also having same issue. :frowning:

Hey,

I contacted UiPath support whom pointed out:

A) It’s X-UIPATH-OrganizationUnitId

B) The payload needs to contain json keyword in the header. Such as:

start = requests.post(base_url+“Jobs/UiPath.Server.Configuration.OData.StartJobs”, json = start_data, headers = start_header)

1 Like

Thanks for sharing! @guemi

Now I’m trying to using Postman for start job, so I put folderId for X-UIPATH-OrganizationUnitId…
but I still got same message. “startJobParameters must not be null” :disappointed_relieved: :disappointed_relieved:

I have no clue what to do :scream:

You’re not attaching start_data in your header, are you?

This is what I run:

And start data is:

bild

Please add key json with value this: bild

Also, if you’re a paying customer I can highly recommend the UiPath support. They’re fantastic.

Ok, I’ll try it again. thanks for the reply :smiley: :smiley:

Let me know how it goes :slight_smile:

I solved it! Problem was body, not the header… I changed all body parameters that starts with lower case to upper case (ex. releaseKey → ReleaseKey) :sweat_smile: haha…I don’t know why i did that but anyway it works! :heart_eyes: thanks for your help

Has anyone tried using this API call with Input Arguments?

I’m revisiting this item after a while. And this API call still continues to be a nag.

I am able to run my jobs by passing input arguments from Postman. Works without any issues.

However, when I run the same thing from a ZOHO Flow, I get the same nagging error several members have already experienced on this forum.

I have checked the request body several times by debugging the ZOHO flow, and I have no idea why it works in one place and fails from another. :thinking:

Here is my Postman request body that works flawlessly.

And the same body when triggered from ZOHO , crashes and burns!

The only difference is that the request body is built via a Deluge script. I have checked the syntax of the body several times as it is written to the output (as seen above) and I don’t see any variations. Not sure what the problem is.

Responding to the original issue posted by @m.choi so that it may help others in the community.

The problem I posted on Oct 17 was traced to be an issue with nested JSON when the API call was executed from ZOHO CRM. Therefore, please ignore this part of my post!

The StartJob API worked when the API request was composed in this manner below

Request Body - Those in Red are required

image

Headers:

image

FYI and thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.