Start job API returns a status code as 200 and XML as response

I’m trying to start a job using orchestrator API. I’m able to start the job using swagger but the same values are returning status:200 and response as “uipath…community” in XML format.
Could anyone let me know, Why am I getting this error and how to solve it?
Thank in advance.

Hi @Techie

Welcome to our UiPath Forum! :slight_smile:

Are you using the Orchestrator HTTP Request activity? Could you post some screenshots of the way you have it configured?

I’m using http request activity.
Build jtokenwriter variable and passed in html request body.
I’m facing the same issue when tried to schedule the job also.

I also tried passing values as parameters to http request command and constructing the input(body) string in JSON format and passing.

Hey loginerror, I’m getting the same scenario here :frowning:

I even tryied to put the Organizational Unit as a parameter… but nothing changed.

Can you help me?

Hi @tiago @Techie

Could you provide a screenshot of how the call looks like in Studio?
I would certainly make sure that the content type is set to
image

Dude, I’ve realized that when I moved to Postman app instead of using SoapUI, it started working without doing any changes.
Sorry for not updating this post with this information.

1 Like

Hello All,

I’m getting this HTTP 200 when I use start Job API with Jobject as input parameters. Can anyone please help me on what is missing ?

Hi @yashaswiniGowda

You can go to your Orchestrator in any browser, inspect the Network (Ctrl+Shift+I, Network tab) and then do the action you want to perform (in this case, start a Job).

You will be able to study the request and it’s parameters :slight_smile: