Unable to run batch file in Uipath 2020.4.1

Hi All,

I am unable to trigger UiRobot from the batch file. Used multiple ways of like this but they are too not working.[An execute also before --file “C:\Users\aparna\AppData\Local\UiPath\app-19.12.0-beta0061\UiRobot.exe” execute --file “D:\aparna\UIPath_Projects\Platform_Test\Robot2_NotePad\Main.xaml”]
I am not using Uipath assistant just because excel files beneath the folder structure do not gets modified when I run the robot from an assistant. As we publish code to tray excel files are locked & when code executes it still reads the existing data.
Help me execute the .bat file as that’s the best way we can have robot triggered.

@Aparna_Chaudhari,

Please share the error or log. Meanwhile check the UIPath robot exe exist on current path. Second publish the package and give the path of nupkg file.
For reference this bat file is working fine on my machine.

Regards
Anand

This is the documentation for that task: https://docs.uipath.com/robot/docs/arguments-description but from your command we can see that you are executing an older beta version and not 2020.4.1 robot.

I am not using the beta version so my Robot.exe resides in C:\Program File x86\UiPath\Studio\UiRobot.exe

There is no Robot.exe C:\Users\xxx\AppData\Local\Uipath\

@Aparna_Chaudhari
OK. So you are giving the same path on bat file?? Can you share the screenshots of Robot.exe file where it exist in your machine?

Regards
Anand

Hi please find the below screenshot which shows the location of UiRobot.exe

Can you try this by putting the project in C drive?

Regards
Anand

Maybe you have mixed versions there, community edition with enterprise trial in the same PC… cause the command UiRobot.exe execute --file "C:\UiPath\Automation\Main.xaml" would be ok if your installation is good.