Unable to access Orchestrator

Greetings all,

Really hoping someone might be able to advise on the issue I’m encountering here -
When navigating to https://uipathserver.cobwebb2.local/ I receive the following error:


Server Error in ‘/’ Application.

Cannot open database “UiPath” requested by the login. The login failed.

Login failed for user ‘COBWEBB2\UIPATHSERVER$’.

Uipath web.config contains:

<connectionStrings>
<add name=“Default” providerName=“System.Data.SqlClient” connectionString=“Data Source=UiPathServer\UIPATHSQLSERVER;Initial Catalog=UiPath;Integrated Security=True;” />
</connectionStrings>

  • UIPath database is on a UIPATHSQLSERVER named instance on the same machine.
  • TCP/IP and Named pipes are enabled.
  • ODBC configured and connects.

Would very much appreciate any help/ideas.

Thanks!

Installer: (.msi)

License type: (Free, Trial)

Studio/Robot version: (UiPathOrchestrator2018.2)

Current behavior: bad

Screenshot:

1 Like

@Grant_Steadman
Did you ever resolve this?

I ran into the same exact error. When you installed Orchestrator, did you use the default Application Pool Settings configuration via an AppPool? If so, I found a few solutions.

Reason for Error:
The login doesn’t have sufficient role permissions / rights to the database.

Solution 1:
Run the Orchestrator under a specified Windows identity. Instead of creating role privileges for the App Pool, just rely on an account login. You can do this via the IIS Manager.

Solution 2:
Add permissions to the AppPool. The first part of this is ensuring that the AppPool has permissions to the Orchestrator folder.


In addition to this, you may have to add the account to the SQL security logins.

Hope this works!

2 Likes

Thanks all.

Issue resolved with both Solution 1 and Solution 2 (https://stackoverflow.com/questions/7698286/login-failed-for-user-iis-apppool-asp-net-v4-0) as mentioned above.