'UiPath.Core.Activities.AsyncNativeActivity' from assembly 'UiPath.UiAutomation.Activities

Hello. I need help resolve an issue that I am getting in my workflow. My code was working properly and recently started giving me an error. I have tried to upgrade UiPath.UiAutomation.Activities and also tried downgrading to see if that resolves but no luck. Also tried upgrading UiPath studio version but still giving the same error and at this point not sure what is the issue. The issue happens right at the start when it hits InitAllApplication (REF)

Invoke InitiAllApplications workflow: Could not load type ‘UiPath.Core.Activities.AsyncNativeActivity’ from assembly ‘UiPath.UiAutomation.Activities, Version=, Culture=neutral, PublicKeyToken=null’.

Any suggestions that can resolve this would be greatly appreciated :slight_smile:


Hi @Rahim_Bhatia

Please check the below threads:


Most probably you have issues in that Studio/Robot machine and cannot install the UiPath.UIAutomation.Activities.23.10.9 from https://pkgs.dev.azure.com/uipath/Public.Feeds/_packaging/UiPath-Official/nuget/v3/index.json package source.

Check this aspect in the Studio logs. (Ctrl+L)

Hello. Thanks for your help. I tried the solution that you mentioned and the error still remains. Any other suggestions?

Hello. I have the latest package installed for UiPath.UiAutomation.Activity (23.10.9). Also rename that backup file so it installs new file and error still remains :frowning:

What is your Studio version? Is 23.10.4?

For the process and for your custom library if you have one, can you republish by disabling the Separate Runtime Dependencies?

Go to Studio Machine → Start → UiPath Diagnostic Tool → Activities Issue → collect everything → provide the zip file

Open a powershell.exe console, run the below code and provide the results:

Write-Host "`r`n**********`r`n"
Write-Host " System variables:"
[Environment]::GetEnvironmentVariables("Machine") | Format-Table -Wrap -AutoSize
Write-Host "`r`n**********`r`n"
Write-Host " User variables:"
[Environment]::GetEnvironmentVariables("User")  | Format-Table -Wrap -AutoSize