Trying to use String variable in Add Column Activity

Hi Everyone! Having a slight problem that I would really appreciate some help with.

I cannot upload my sequence to this unfortunately however I can try and explain to the best of my ability.

I am trying to add a column to a data table and I want my Input-Column field to use a string variable from elsewhere in my sequence. When I do this I am told that a string variable cannot be turned into a data column variable type. I have tried a few things to rectify this but none have worked so far.

Would anyone be able to give me a solution so that I can use my string variable here?


1 Like

Hi @nrowe - You tried Add Data Column or any other way to achieve it? If you have used “Add Data Column” activity then there is a Property called “TypeArgument” which can be changed to “String”


Buddy @nrowe

as you are trying to pass the variable of type string to the field here column which is of type datacolumn, there is a mismatch in type buddy
try to mention the variable in columnname property of the add datacolumn activity
like this


were you able to add now buddy @nrowe

So I got it working once then tried again and now it isn’t writing my stuff in which is very puzzling

i mean …i didn’t get you buddy @nrowe

Sorry I may not have been very clear I put my variable into the column name and that worked at first. The data table that they fed into was capable of writing into my excel workbook. However I then cleared out the data that was written and ran it again to double check and this time my robot hasn’t written in the data.