Training load from Studio to Data Manager

Hi y’all,

I’m practicing with AI Center and Document Understanding. When loading a dataset for training from Studio, I get this error message:

Captura de pantalla (1417)

I have no idea what it relates to. I’m following this Lahiru Fernando’s tutorial and I don’t know where the problem can be.

Any help or point in any direction on how to solve this issue is welcomed. Thanks!

Hi @ntrtnmntvlt

Can you show what you are doing. If feel you are passing aome wrong file or something or the path is wrong that it says index out of bound

Cheers

I’m trying to extract some data using a ML Skill created in AI Center. The data is stored in my PC, I asign the folder to a variable and load the taxonomy, then iterate each file, digitize and extract the data using the ML Skill (I think that how it works), but I get that error every time.

Hi @ntrtnmntvlt

I hope you are using for each file in folder

Currentitem.fullname will give the filepath… only currentitem wont give you the path of the file. Please change it accordingly

Cheers

It doesn’t allow me to change CurrentItem to CurrentItem.fullname.

I see that the source of the error is always in the Machine Learning Extractor, Exception Type: UiPath.Shared.Activities.TrackingException. Can be that the connection with Orchestrator ain’t well configured?

I created the same workflow previously and it worked, I don’t understand why is giving me problems.

Hi @ntrtnmntvlt

What loop are you using?

As you said each file i thought you were using for eqch file in folder. Can you once print currentitwm
And see if you have the right path

Are you seeing this after upgrading to latest version? If ao in latest there are few bugs and it might be the cause as an alternative for now you can try using windows legacy

Cheers

Yes, this issues are happening after I converted the original project from Windows-legacy to Windows. I’ve replicated the same project afterwards with different tweaks but they all give me the same error.

Thanks for the help, anyway!

1 Like

Hi have you made your ML skill public? You need to make your skill public before you can access it on data extraction scope.

You need to go to your ML skill > modify current deployment > Enable Auto Update.

image

That’s not it. Still getting the same error :sob:

When you go to “configure extractor” in data extraction scope, can you get the settings function? its shown on the top right like this,

image

Click on the settings icon

then add your endpoint and Apikey and click get capabilities

image

Let me know if this works for you. We can see if there’s a connection made.

Hi,

I’m not using an Endpoint, but a ML Skill.

I tried using an Endpoint too but the Error Message is the same.

The thing is that the extraction worked well before the Windows-legacy compatibility update, so I think the problem lays there, because everything worked fine before that. I don’t know what else can I do.

1 Like

I have just seen that, when I run the project, right at the start, this happens:

I don’t really know what is the meaning of this, but could it be the reason why the issue happens? If so, how do I fix it?

Hi @ntrtnmntvlt

Can you try recreating the project. Because this looks like the project files are corrupted.

May be the conversion from legacy did not happen properly

see this

cheers

Hi @Anil_G

I have recreated the project multiple times and always get the same error.

How can I make sure the conversion to legacy is properly made? Should I delete Studio and reinstall?

Hi @ntrtnmntvlt

That is one option(to reinstall). you can check , if the issue might be because of 32 bit and 64 bit as seen in other link that I provided.

As of now Latest version and windows are having issues so not completely sure what are missing and what are wrong

cheers

Great, thanks.
I’ll keep trying :sweat:

1 Like