"The given path's format is not supported" error message displayed in "Use Excel File" activity

Hi UIPath Community,

I have an input dialog activity that gets a filepath of an excel file and then I output it in a variable say “excelFilepath”. This “excelFilePath” is then use in “Use Excel File” activity, problem is I’m getting this error message: “The given path’s format is not supported”. I’m not sure why because at random times it does work, but sometimes it’s not. I tried to log my filepath and I validated that it’s getting the correct excel filepath. It’s just it’s getting this not supported error.


Note: Filepath has japanese characters not sure if it’s the one causing the tool to get that error.

Your help is greatly appreciated.


Hey @elizmarie

Yes, suspecting the same.

The japanese text may be the root cause, Can you just try with different files to check ?

May be with only english names to see…


Hello @elizmarie

Copy that path and try to open it in file explorer. If its working then it should work with Uipath also.

You can copy that file to a new folder and try from that path as well. Also hope you put the url in between double quotes.

1 Like

Hi @Nithinkrishna, thanks for your response. I tried to replace the japanese filename with english one and it works, only problem is we can’t change the filename to english as this is being used by the client. Is there any other way to read japanese characters without having this error? Thanks

1 Like

Hey @elizmarie

Is that possible for you to paste the Japanese language path here please ?


@Nithinkrishna sure, here it is. Thanks

C:¥Users¥username¥Downloads¥RPA バックアップ¥チェックプロセスサマリー.xlsx

Okay @elizmarie Thanks for sharing.

Just try replacing ¥ with "" in code & then print the path to check and pass it to Excel activity.



Can you test by taking the filename and appending it to the end?
fileName = path.GetFileName(filePath).ToSting