Take Screenshot fails in background process on VM when triggered in Orch

This is the background process:

When I run my background process from Assistent it works.

But when I leave the VM and start via Orch it fail all the time with this error:

Btw I tested it on an attended and unattended VM. Same error message!

Is that really intended?

But I need that screenshot on both VMs. How is is possible to take screenshot on VM in a background process?

Here the running services:

and Task Manager:

#1 side notice: we have other process (no background process) that take screenshot, and those are working. So this needs to be something with the background process.

#2 side notice: I also made sure to proper disconnect from the VM.

#3 side notice: very similar issue, so the reason is that when being logged out the screenshot taking does not work anymore, this is intended by Windows, but there must be a workaround that the user stays logged in?

Got an answer from Technical support. It’s impossible with a background process.

So I go for a solution with node.js

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.