Tableau Scope Activity Error

Hi @hanandan

Could you please provide some more information about the way you have configured the activity / your process?

Hi @loginerror Thanks for the response. Please find it below

Inside the config
The site id and view id are the ones I striked in red below

others like password and username looks right. Please let me know

Hu @paul.hoeffer I face an error from the tableau application scope activity. Though the connection is successful. I get the below error

Any help is appreciated.

Hi - either @robert.wagner or @Subrahmanyan_Sankaran can assist.

1 Like

@hanandan maybe you receive an unexpected response due to wrong connection resource?

1 Like

Hi @robert.wagner thanks for those screenshots. Looks like the connection resource that I use is correct. Before I used to get the tableau scope activity Block’s output (Connection) of Design connection as input for Robot connection by selecting existing connection and corresponding O/p name.

So, this time I tried to change based on the screenshot by again giving the credentials for Robot connection same as Design connection. However I am not able to use the same password as I gave for Design Connection. My password has ‘@’ in it and the field doesn’t accept inspite of the same password getting accepted for Design connection.

So you can connect successfully in connection configure window but not when you run the robot, correct?

Are you using a secure password? It should not matter if there is an “@” in it or not.

You can use this string to create a secure Password:
new System.Net.NetworkCredential(“”, “passw0rd”).SecurePassword

@robert.wagner Yes exactly

I do not have a password for Robot connection in the right since it is not accepting. But i will try with your suggestion and get back

Hi @robert.wagner this time it throwed a different error

Please let me know if that was the right way to create secure string.

Please make use of variables:

Hi @robert.wagner I tried using the variables. but getting the same error as previous one.

Again the connection is successful. So regarding the

new System.Net.NetworkCredential(“”, “passw0rd”).SecurePassword

I believe I need to replace “passw0rd” with my actual password right. Please correct me if i were wrong. Aslo, for Design connection credentials I entered them as how they are (not variables i.e., ctrl +k ). Also for Robot Connection is it just the passowrd and username we need to enter as variables or everything (Sitename, TableauServerURL). Please advice

Yes you need to insert your password and replace “passw0rd”.

There is multiple ways to deal with credentials and I would like to recommend to get familiar with this:
This is my preferred approach to deal with credentials.

But I also found this in forum which might will help:

Hi @robert.wagner Thanks I will go through. Also, can you please let me know about declaring other information like (Sitename, TableauServerURL) for robot connection part. Do they need to be declared as variables too?.
One more thing I realized is that i do not have UI path Robot installed yet. Since we use Robot connection here am not sure if that is causing an issue. Please advice

I’ve merged the discussion into one separate topic.

1 Like

There is no need to make for instance Sitename variable. You can if you want but it works also as shown in the screens.

@One more thing I realized is that i do not have UI path Robot installed yet. Since we use Robot connection here am not sure if that is causing an issue. Please advice

I assume you mean Orchestrator? If so, yes this is an Orchestrator feature.
You cannot use this feature if you do not have an Orchestrator set up.

You will have to go with secure passwords created in studio:
new System.Net.NetworkCredential(“”, “yourpassword”).SecurePassword

1 Like

Hi @robert.wagner I was able to fix the error from tableau scope activity. I missed the quotes (“xxx”) in the username part of my ROBOT CONNECTION. Thanks for the support.

However I am trying to get the whole underlying data from my view and not just the summary data. But when using the download cross tab data activity the downloaded .xlsx file shows an error when opening. it says the file may be corrupt or similar. Any thoughts on why this is happening.

I just tried this and it looks like this is happening when the returned result is empty?
Can you check if you get results?

Hi @robert.wagner Thanks for the continuous support. Even to check the returned results I am not able to open the downloaded .xlsx file. And just to reiterate . My expectation is the DownloadCrosstabexcel activity gives the whole underlying data and not just the summary or view specific data. Because the query activity works returning a summary data.

@hanandan I think I found the source of the issue now!
Can you please set the version in the robot to “3.10”? Do not forghet the Quotes.
Per default it is using 3.4 and this feature is not supported for this API version!

If this is the case, we will try to implement and throw an error in the future in case this is happening!

1 Like

@hanandan can you please let me know if this helped to solve the issue?