System.Exception: Job stopped with an unexpected exit code: 0xC06D007E

Hello, I need help with this error. Everytime a connection is made to the Microsoft access database, after 10 seconds this error pops up. With connection commented out, it works fine. I updated all packages, still haven’t found any solution.


Check these possible solutions:


It’s a well-known fact that some antivirus programs are capable of overreacting, causing a series of system errors. The Unknown Software Exception (0xc06d007e) issue could be a case of antivirus overreach. Your system protection program might be blocking some files related to the program you’re trying to access because the antivirus thinks it’s a threat. While you cannot be too careful when protecting your computer, it’ll be great if your antivirus knows not to overstep.

Some users were able to get rid of the error message by completely removing their antivirus programs. So, we suggest that you start by disabling the program to confirm whether it’s the reason for the problem. If you don’t see the problem anymore after disabling your antivirus program, go ahead and update it.

Take a look here Unknown Software Exception (0xc06d007e)

Also, check if in your workflow you are using an Excel activity that has a fixed Range and all the Excel activity is going in a long loop. If yes, you may need to reconsider the Read range and the amount of data to be manipulated.

In case you are using BeyondTrust PowerBroker and you have errors in the Event Viewer logs right before the Executor crash event:

BeyondTrust PowerBroker is a privilege management tool installed on machines to control user access which seems to be the root cause of this issue.

So. please reach out to the internal IT Team to create a rule inside BeyondTrust PowerBroker to allow all the files contained within the UiPath’s installation directory to run.

Thanks for the response, however, I tried the steps above, they didn’t help. Ui Path worked fine a few months before, maybe it has to do something with updates.

What you updated or what exactly was updated in the respective machine?

I tried updating packages. It has to do something with database activity as there is an Error in log file. However I tried deleting this particular folder and installing again, but the error is the same. [ERROR] [UiPath.Studio] [28] Bad IL format. The format of the file ‘C:\Users.nuget\packages\UiPath.database.activities\1.7.1\lib/net5.0-windows7.0/runtimes/win-x64/native/Microsoft.Data.SqlClient.SNI.dll’ is invalid.

After this follows the

[ERROR] [UiPath.Studio.App.Logging.OutputLogger] [48] System.Exception: Job stopped with an unexpected exit code: 0xC06D007E

Ok, so I think you migrated to the Windows project and now you are facing these issues.

Alternative solution until the Windows version net5.0-windows7.0 of the package UiPath.Database.Activities[1.7.1] will be fixed → Use a Windows – Legacy project

I tried connecting to the same database, in a new Legacy Project, however, it shows an error Microsoft.ACE.OLEDB.12.0 provider is not registered, looking into the error, it says I should install AccessDataBaseEngine file, but why on Windows project it doesn’t require the update?

The Microsoft.ACE.OLEDB Provider Is Not Registered On The Local Machine

Solution: Install 64-bit Office.

Check this article also