SFTP Connection Issue

I’m using FTP.Activities getting error “FTP Scope: Permission denied (password).”

While connecting with WinSCP, I’m providing username, password, host, password and google auth otp

But while connecting sftp through UiPath getting above error, Where to use OTP?

Check this out on how to set FTP activity

Let us know if u r looking something different

Cheers @Afzal_S

Can you show how you provide this in WinSCP?


Here i need to add google auth otp

Here is the code:


After getting “Get Google Token” I’m confused where to use it.

I could be wrong, but to me it seems it’s not possible with the UiPath FTP package. If that’s indeed the case, I see a couple of options you have:

a) Check if it’s possible to create a new user account for robot user that doesn’t require 2FA.
b) Have the robot use WinSCP via UI to access the sftp.
c) Use WinSCP library in a custom activity. Some examples of using the library can be found here WinSCP .NET Assembly and COM Library :: WinSCP - https://winscp.net/
d) Extend the code in FTP package to allow for 2FA. Source code can be found from here: Community.Activities/Activities/FTP at develop · UiPath/Community.Activities - https://github.com/