Send SMTP Mail Message Authentication unsuccessful


Can anyone help me understand why this error message?? where as if I keep my credentials hard-coded in the activity then its working fine but when using the same via Get Credential its giving me this error.

Send SMTP Mail Message: 535: 5.7.3 Authentication unsuccessful [BM1PR01CA0152.INDPRD01.PROD.OUTLOOK.COM]

P.S - I can read email with using the Get credential.

@Pablito @loginerror @ovi


Check below for your reference

Hope this helps you


1 Like

@Srini84 , thanks for the reply but unfortunately it’s not helpful.

Hi @indrajit.shah ,

Have you enabled less secure apps in your gmail account ?Kindly enable less secure apps then you will able to send the mails. use below link to enable.


I am not using Gmail

Hi @indrajit.shah

Which domain mail u are using ?

Its office365 and i am using the correct configuration as i tried the same SMTP configuration with credentials hard-coded in the code and it worked but for when passing the same from asset credential(user name and password only) and rest the configuration through variable, its not working.

Did u convert the password retrived from the asset to string ? @indrajit.shah

No, but I decrypted the password from the secure string and checked.

Hi @indrajit.shah

Did you find the solution? I am also facing the same issue.


Using the Get Secure Credential Activity to retrieve the user name and password from windows credentials. But send smtp do not work with secure string. For plain string it works fine.

No @kumar.varun2 , I didn’t found anything, I guess this is to do something with the smtp setup.


apparently the secure password option is not working correctly, use the following method to use the password from the orchestrator in the password field that takes a string

New System.Net.NetworkCredential(String.Empty, VARIABLE).Password.ToString()

VARIABLE = variable secure password that comes from the orchestrator

@joao_adelio1 in my case I did convert the secure string to system string to cross check the value of the credentials and I found it it’s getting the correct value but unfortunately not working in the flow.

@joao_adelio1 As I wrote in another thread, there was an issue with SecurePassword that has been fixed since version 1.9.6.

THANX - it did the job for me :slight_smile:

hello, i’ve read your answers on both threads and that concerns the secure password
however i’m getting the same issue with password as regular string since 1.9.6 and i’ve been using 1.9.5 to avoid that but i have to update and even with 1.10.5 i still have the issue
both mail and password are string values in the activities ! any recommendation ?