Screen Scraping not working anymore

Hi, I have a problem with Screen Scraping in a pdf, I developed a robot a long time ago (~1 year) and it was working fine with screen scraping activity, but for like 2-3 months now it stopped working properly, it can not read the same content/text as before and I tried to fix it but can’t. I would like to avoid read pdf activity, because it would be essentially a new robot development. The pdf files contents never changed, so that’s not the problem.


Welcome to the community

Please try using modern activity inplace of the classic activities and check…



Hi Lrinczaron,

Please check the Package version it is updated or not.

1 Like

I updated the packages, it still doesn’t work

Hi @lrinczaron,
There could be a few potential causes. Here are some things to check:

  1. Check if the PDF file format has changed: If the format of the PDF file has changed, for example, if the font or layout has been modified, the screen scraping process may not work as expected.
  2. Check if the PDF viewer has changed: If the PDF viewer application has been updated or changed, this could be affecting the screen scraping process. Ensure that the PDF viewer is still compatible with the version of UiPath you are using.
  3. Check if the screen resolution has changed: If the screen resolution has changed, this can also affect the screen scraping process. Ensure that the screen resolution is the same as when the process was working correctly.
  4. Check if the selectors are still accurate: If the selectors used in the screen scraping process are no longer accurate, it can affect the results. Review the selectors used and update them if necessary.
  5. Check if there are any system or software updates: System or software updates could also affect the screen scraping process. Ensure that the latest version of UiPath and all relevant software updates are installed.

Sorry, but can you explain what do you mean by that


In screenscrapping you would have used get full text or ocr text and all…

They have new activities for the same in modern design…

Get Text helps in getting the full text or native text

If you are unable to see…then click activities → filter icon → show modern


1 Like

I believe everything is the same, except maybe for Acrobat Reader version, so that may cause the problem? If so is there anything I can do to revert it?

you can try updating or downgrading to a different version of the software. You can also try repairing the installation or reinstalling the software altogether.

  • To update or downgrade Adobe Acrobat Reader, you can go to the Adobe website and download the desired version of the software. Make sure to uninstall the existing version of the software before installing the new version.

  • To repair or reinstall Adobe Acrobat Reader, you can go to the Control Panel in Windows, select “Programs and Features,” locate Adobe Acrobat Reader in the list of installed programs, and select the option to repair or uninstall the software. If you choose to uninstall the software, you can then reinstall it from the Adobe website.

1 Like

Thanks for all the help unfortunately nothing fixed it so far :slightly_frowning_face: