RegEx match not appearing in my output

Dear UIPath,

I’m trying to filter text from a pdf by using a RegEx expression “(?<=Tof MS\s)…[0-9]+”.
It needs to filter four rows of numbers after “Tof MS” i tried but with no result (?<=\n)\d[0-9]{0,5}…[0-9]{0,5}…[0-9]{0,5}…[0-9]{0,5}.

The builder sees my expression correctly, but it won’t print it the output whenever i run my script.

Please help


it might be line break matter. Can you try either of the follownig?

(?<=Tof MS\s+)…[0-9]+


(?<=Tof MS\r?\n)…[0-9]+


Hi @uiStijn

Welcome to UiPath community

Can you share the sample input with us.



Hi @uiStijn
Try this

(?<=Tof MS\n)[\d\W]+


Thank you guys for the input, sadly i got no output of the expression.
I can’t upload my sample yet because i am a newbie so i made a link.

The above values need to be found with the regex command. They are random and can be 0-15000 and sometime have a >or< before the value.

Fixed it. Printed the ‘Read PDF text’ activity to a log and saw that i had made a mistake.
Thanks for helping!

Kindly mark the solution which is helpful for you, it will help someone who is facing the same issues.

Happy Automation

Gokul Jai

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.