Read range work makes an error

I’ve selected the xlsx file I want to read, inserted the sheet name and connected it to the datatable variable, but when I run the fil this is the error I get:

Hi @ani_panch

Select entire path of the excel file and check.

It gave another error

Hi @ani_panch

Excel file you are reading is empty. There is no data in that file. Hence it gave object reference error.

Hi @ani_panch

Check the excel file has data or not.

it doesn’t because I’m extracting data from invoice and inputting in the file

Then use write range workbook activity. It writes the data table into excel file.


If u try to store empty data from excel to data table it will throw error. Give default value of the data table variable as New DataTable in the variable panel and check once.

I deleted that step but now I have an error here: It asks me to insert something into DataRow. What should I put there?

Nothing. If you pass array of datarow, you need not enter datarow. Keep it empty.

Here’s the error, I really don’t understand why it’s not working, I’m following a tutorial…

There is no data in at least one of those variables which you have passed inside a array.

Hi ,

Can u please try by upgrading package version for excel.


Hi friends, thanks for the responses, I solved the problem the following way: added headers to the columns in excel file. Afterwards every step worked: from read range to add row

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.