Read CSV Error: Method not found

Hi, guys,
after upgrading and downgread installed Uipath.System.Activities packages I cannot get rid of csv error:

Read CSV: Method not found: ‘Void CsvHelper.CsvParser…ctor(System.IO.TextReader)’.

Any advice, how to solve it?

which version would be worked?

1 Like

give a try also on updating the UiPath.Excel.Activities

Take a Backup of the entire Project/Xamls before doing this



Have a view on this similar thread and solution

Cheers @111962


And also try uninstalling if any Salesforce Package installed and work with CSV activity

Cheers @111962

we would recommend to focus on the issue to get it sorted out. Maybe UiPath Tech Team will also be looped in.

In case of urgent delivery need we can do following workaround:

  • read text file
  • generate datatable activity and parsing the csv data into a datatable
1 Like

Thank you very much for your quick reply.

I thought it maybe the problem of Uipath.System.Activities package.
it turns out that this error resolved by also updating the UiPath.Excel.[Activities]

Thank you very much!

Hi, Thank you for your quick reply.
I checked this similar thread, but I’m just a little confused about what the solution is.
so I asked from here.

now I solved this problem by also updating Uipath.Excel.activities package. thank you.

perfect. May we ask for the following. So others can benefit from it

Forum FAQ - How to mark a post as a solution - News / Tutorials - UiPath Community Forum


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.