Python 'utf-8' codec can't decode byte 0xa3


I am currently Challenged by the Python package. I am trying to call a python script.

Unfortunately, I get the following error:


I have set the python scope up correctly, as I can run other scripts. however, for this more complicated script, I get an error.

  • I can also run my script directly from my command prompt

I run python 3.6 (64bit) - cannot run 32 due to memory issues

can someone help?

Hi @Ecperlux

Could you provide a sample of the script that doesn’t work?

Hi Loginerror

thank you for the response. I found the solution. it was due to the way UiPath tried to decode the code, which were incorrect. but I found a solution!

thank you though!

I’m glad it worked out :slight_smile: Feel free to share so hints on how to solve it if you think it could benefit other users.

Had to look into the issue again to explain.

the solution to the issue to add a “load python script” prior to my big code, which imports certain libraries, in order to run my other code. so basically had to split it



Can you please let me know what libraries were imported?

Few screenshots would be helpful.

import codecs

should be run prior to your mainscript

Thank you.

For me, import codecs didn’t help but when I saved my Python code as ISO-8859-1 instead of UTF-8 (had to replace the Scandinavian characters that caused issues with UI Path in the process), then UI Path loaded the script without any issues.