Python Integration (Pipe is broken)

Hello there,
I have problem with python integration when I import some libraries as shown in the 1st picture
it shows me the message: “pipe is broken” as you can see in the 2nd picture; However, we tried to run another function from the same file without the import part and it worked, so does anyone have any idea how this can be resolved.
pip is broken

does this help?

@Hisham_Alshareef

Could you please try placing the import Statements inside the function and Check?

Example:

 def regonize(full_name):
        from compreface import CompreFace
        from compreface.service import RecognitionService
        return full_name

Also, check the pip path on the system environment variables.

Thank you @Hari_Balaji

It seems the problem with the library itself. Have you faced a similar issue?

Regarding to the Pip path it is already checked and has no problem.

@Hisham_Alshareef

Could you please provide more details regarding the library you are using?

Thanks!

@Hari_Balaji

The library i am using is

CompreFace — Open source Face Recognition Service | Exadel

@Hari_Balaji

So have you faced a similar issue?

Hello @Hisham_Alshareef ,

SO from the IDE, is it working fine and only if you are invoking it using the uipath its throwing some error? If its working in IDE, can you check to which python version IDE is configured and can you try giving the same in UiPATH as well.

Hello @Rahul_Unnikrishnan

It is working fine from the IDE ,only in the UIPath when i invoking the method it throws me that error (Pipe is broken) . And I gave the UIPath the same version as it is in the IDE which is Python 3.8.10

Hi I face a similar issue, were you able to solve this?

1 Like

The Python library I am using can give an API result, so I used Http request to call the API result instead of python integration, because regarding to Python integration it seems there is no solution yet.

1 Like

Thank you :relieved:

If you are using legacy-windows make sure python is installed as 32-bit.
If you are using windows or cross-platform make sure python is installed as 64-bit.