Problem with uploading .net6 nuget package to Orchestrator to be used for Windows project


I have developed a Windows Project solution in UiPath that uses a nuget package that has been build and created from a .net6 class library project in Visual Studio. The package works perfectly in my solution when running attended in Studio.
Now I need to run the solution unattended from the cloud Orchstrator. In order for the solution to be able to be run unattended it needs to install the .net6 nuget package from the Orchestrator also and I have therefore manually uploaded the same nuget package used in my solution to the Orchestrator. The uploaded nuget package is unfornunately only recognized to be compatible with Windows - Legacy (.net461) after upload and not the expected Windows (.net5.0 or higher) compatibility. Due to the incorrect compatibility I get the following error when running the job in Orchestrator:

UiPath.CoreIpc.RemoteException: Failed to install package ‘’ —> UiPath.CoreIpc.RemoteException: Failed to download package ‘FS_OA_RPA_123_RPA_Workzone_Client.0.0.8’ from ‘’.
Response status code does not indicate success: 403 (Forbidden).

I guess the error simply indicates that the package it looks for is not compatible and therefore the forbidden 403 error.

Does anyone either know what I should or could do to uploaded the nuget package such that it is recognized with the correct compatibility or know if I should take some other approach for uploading the nuget package?



Welcome to the community

Just to confirm when you use the pckage are you installing it in windows oe windows legacy compatibility?

The project you created to run the package is windows comptibilty or legacy?



All projects involved are Windows and not legacy projects.
The main problem is that when uploading the nuget package to Orchestator it is somehow recognized as Windows legacy compatibility even though the target framework for the nuget package is net6.0.

What I have tried since posting this topic was to update the nuget package with the nuget package explorer and adding a net6.0-windows7.0 target but still no luck.

Further I have discovered that my .NET solution uses some dependencies that only target up to .NET 4 so maybe this could be some deep nested cause to the problem?

I found a solution for now but I don’t think it is quiet optimal though.

Instead of just uploading the nuget package to the Orchestrator I found out that I could try to copy the resulting produced nuget folder for my .net6 solution (which was installed/created the first time I ran my process in Studio) into the .nuget folder on the machine where my unattended robot should run. This way the Orchestrator did not have to install it and therefore no problems occured.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.