Problem with UiPath CLI

Hi all,

I’m trying to build a CI-CD pipeline using the UiPath CLI on GitHub Actions.

I’m having problems with packing projects that use our self made libraries and are build using windows framework. Other projects that are built using legacy frameworks works perfectly.

I have tried to use different package versions and I know that the problem is not with the running environment since I get the same error when running the command locally

Here is the UiPath CLI used for packing:
UiPath.CLI.Windows - 23.6.8581.19168

Here is the error message I get when packing a project with the UiPath CLI:

All our projects and libraries use the newest packages
UIAutomation.Activities - 23.10.3
System.Activities - 23.10.2
Testing.Activities - 23.10.0
WebAPI.Activites - 1.18.0

The packing and publishing works perfectly when publishing projects using UiPath Studio.


1 Like

From what I tested, this is replicable if you created Windows custom libraries in a Studio 2023.10.0. Apparently, the UiPath.CLI.Windows - 23.6.8581.19168 version is not compatible with such libraries.

Try these:

  • Create a new Windows library and a process in a Studio 2023.4.5, then retry the packing using the uipcli.exe package pack command.

  • Remove the Windows custom libraries from your Studio 2023.10.0 process and retry the packing.

New CLI was posted last week.

Can you give that a try?

And let me know if you find any release notes - I have not been able to find any yet

It seems the new CLI version 23.10.8748.26621 solved the issue for the processes that have Windows libraries built in Studio 2023.10.0.

The release notes should be found here Test Suite - UiPath CLI Release Notes

Note: But apparently the team is not keeping it updated.


Yes, and sorry for not being clear. I have also found the page you are linking to, but i was looking for release notes specifically for the new version :smiley: