Problem with highlight

I’m doing this exercise:

Create a process that navigates to the Work Items page in ACME (www.acme-test.com) and highlights the Type cell on the first page of the table.

  1. Ask the user what workflow type to highlight (WI1, WI2, WI3, WI4 or WI5).
  2. Navigate to ACME System 1 - Log In.
  3. One by one, highlight all cells in the Type column on the first page which match the user choice.

I’m not sure exactly what I have to do and maybe that’s why I don’t understand what’s wrong. Actually the terminal doesn’t give me any error but when running the project it does nothing.

That I have to do? that could be happening?


@Carmen_Tur

As you place a breakpoint there in Find childrens activity

Can you check if you are able to get the childs into the Find Childrens variable in locals pane?

If not you have to fine tune the selector

Hope this will help you

Thanks

Yes, I can.

It stranger is… the terminal doesn’t give me an error. Only it run, it doesn’t make anything more.


This is my complete workflow.

Hi @Carmen_Tur

Created a xaml file similar to your requirement refer below!

test_sequence.xaml (8.0 KB)

Regards

I don’t understand your workflow… :woman_facepalming:t2:
why and for what do you use GetAttribute activity?
I have tried to copy it but so much yours and, if I follow your steps in mine, do not work, it crash it.
The one that I had raised doesn’t enter the loop but the terminal but at least doesn’t crash it.

Thank you so much for your time, but I need other options. Thanks!

Hi @Carmen_Tur

As per my understanding!

You need to get input from user any of the WIID!

If it’s nothing it will display invalid WIID

Else you re attaching the browser of acme work items page

Then you are highlighting the WIID in first page based on the user input.

If I am right then the above sequence will work!

Its a alternate way of doing the same

Regards

Totally true, but for some reason the workflow that you have passed me it does crash and mine doesn’t enter the loop For each item in ResultFindChildren, this loop highlight each item from 1st page (taking the desired type into account)

In your workflow, since I don’t quite understand what the GeAattribute activity does, I wouldn’t know how to tell you why it does crash, and in mine I don’t understand why it doesn’t go into the loop…

:woman_facepalming:t2:

Hi @Carmen_Tur

I used get attribute to get the table row of the Highlight column we need to highlight.

Regards

Thanks for your time and giving me other alternatives. :smiley:

By debugging and using the Local panel and the Call Stack panel, I was able to see why my workflow, although it didn’t crash, didn’t go into the Loop (ForEach activity).

The reason was, when writing in the InputDialog activity, in the Input Options Array field I wrote the options array (WI1, WI2 and so on) with a blankspace before the string and the web tag don’t have spaces, so it didn’t recognize the string and didn’t enter in the Loop. Once I was corrected this error it has worked perfectly.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.