Potential Issue: Multi Assign Activity Unable to Assign Enum Values

For some reason, i can’t find a category to report an issue, and i’m not sure if this is truly an issue or not.

I have a property in a custom data object class, that the values you set come from an Enum list. I was amped to see that Multi-Assign activity. In my instance, I attempted to perform a multi-assign with one of the values to assign as that enum val, so an example, i have a custom class called AccessRequest (named ioAccessRequest), and I’m attempting to assign a Passed value from the AccessRequestStatuses enum list:

ioAccessRequest.Status = AccessRequestStatuses.Passed

I had this code in my library, to which i published it, and downloaded into a project i was working on. When i did that, i received the following error:

"The private implementation of activity “1.2: Test (my library activity name)” has the following validation error: ‘Value’ argument is required in assign operation number ‘1’. the message repeats itself. This error message is thrown when i drag the Test activity from my library into my project.

If i replace the multi-assign with the plain old assign activity, it works fine. I’ve looked through the documentation of the Multi-Assign activity, and there is nothing specifying special restrictions. Figured it may be an issue. Please note, this only occurs when a multi assign is within a library, as far as i can tell.

Eh, it now seems like multi-assign in a library is a problem, regardless of type. Avoid using multi-assign within a library, if you’re getting odd errors when using library activities in your project. It makes no sense, i feel like i backed myself into a corner, but i’ve recompiled and tested this over 3 dozen times to find which line item is causing the issue.

1 Like

Thank you for your suggestion. I added it to our internal ideas tracker for our team to consider.

1 Like


Hello Pawel,
I can confirm this behaviour. But im my case is it a simple sequence with a few assigns and an Invoke Code activity.

Thanks for your support.
Best regards

1 Like

@StefanSchnell / @rhibbert I know this is an old thread but we are trying to fix this. Unfortunately, I was not able to replicate the issue. Tried with both 21.10 and 20.10.

Can you please share a sample workflow?

1 Like


Hello Alexandru,
thank you very much for your reply.
With version 21.10.2 all works well, I tried it this morning.
Best regards