Not able to publish a process after adding Trigger Scope activity

I tried to create a process trigger scope activity and is working as expected from studio but when i try to publish the same I am getting below error.

To confirm the issue is caused by Trigger Scope I removed that activity and published and no issues then. The workflow doesn’t has many functions or activities

Thank you

Maybe the j needs to be in double quotes because it’s a string?

I tried with other triggers as well but I have the same issue. Its working when executed from Studio but not able to publish. This given trigger also is working from studio, issue is when I’m trying to publish.

I did try what you recommended, its the same

I would try different versions of UiPath.System.Activities. Could be a bug in the version you’re using.

Yes I did try downgrading to previous stable version of UiPath.System.Activities and UiAutomation activities. But it didn’t work.

I will try to use an older package version and recreate the flow again.

That didn’t work either

Hi @Athira

Would you mind attaching a zip of a dummy project that reproduces this issue, together with the information about the Studio version that you are using?

It would help us reproduce this issue.

Sure i will do that, i just don’t have access to machine right now. Anyhow the project doesn’t contain any other activity only the one shown in that screenshot. Also for this one i used the community version. (2.6 KB)
Attaching the file