Mobile Device Connection Step by Step Guide

Hi, just wanted to update I had the same issue and this actually worked for me:

“build-tools;29.0.2”

1 Like

Watch out this video for complete Uipath mobile automation step by step guide.

Hi, Can you please provide steps for iOS configuration as well?

Follow below steps:

Hi

I understand you, you are going to follow these steps for the problem with the App.

  1. go to this link BrowserStack Login | Sign Into The Best Mobile & Browser Testing Tool
  2. you select Appium
  3. search Step 2: Upload your App, and upload the app

image

  1. you are going to copy the capability
    image
  2. you are going to create a new capability in your devices called “app” and in “values” you paste what was copied in step four

and ready :slight_smile:

browstack will store your apps. As you are creating a capability “app” within your Devices you will not have to create a new “application” in the Device Manager

Even you can do the same with Mac Machine and pass the MacMachine IP address and your system and the Mac machine should be in the same network’

thanks to @Santiago_Alexander_Astros

When trying to connect Emulator from Uipath ( mobile Device Manager) getting below error . Can any one please help

A new session could not be created. Details: io.appium.uiautomator2.common.exceptions.NoSuchDriverException: A session is either terminated or not started (SessionNotCreated)

Please see Unable to connect with Appium - #2 by phaserescu

If you’re using Appium 1.20.0, there is a known issue with that version of Appium.

i am using Appium 1.20.2

1.20.x is broken for MobileAutomation activities. Try 1.21 or anything older between 1.15 - 1.19.

i downgraded to 1.15.0 . still not able to connect . Getting below error.

A session is either terminated or not started

Thank you very much , i was able to connect . i had given time out , which i removed and it worked :slight_smile:

@phaserescu Hi Cristian,

I was facing the issue for appium 1.20.2 now i downgrade to 1.15.1. but now it is keep connecting. not showing any logs or error. can you please tell me where i can see the actual logs like we can see in appium desktop app.

I’m not sure if in this state the logs are available in MDM (DEBUG LOG section). If you manage your appium server, you should see the logs in the console or you can even start appium using the Appium Desktop App and see the logs there.

I tried to see the logs in desktop app, but problem is it is starting the 1.20.2 server there… and showing same issue.

So how do you start the 1.15 appium then?

Through cmd

so your logs should be on the console, in the cmd window you start appium.

These are the logs in attached fappium-server-logs.txt (29.3 KB) ile.

@phaserescu It installed the file in emulator app but connection got terminated.
Here it is getting failed it seems:( attached are the full logs)appium-server-logs.txt (29.3 KB)
[WD Proxy] Proxying [POST /session] to [POST http://127.0.0.1:8200/wd/hub/session] with body: {“capabilities”:{“firstMatch”:[{“platform”:“LINUX”,“webStorageEnabled”:false,“takesScreenshot”:true,“javascriptEnabled”:true,“databaseEnabled”:false,“networkConnectionEnabled”:true,“locationContextEnabled”:false,“warnings”:{},“desired”:{“platformName”:“Android”,“platformVersion”:“11.0”,“deviceName”:“emulator-5554”,“newCommandTimeout”:300,“shouldUseCompactResponses”:false,“elementResponseAttributes”:“rect”,“autoWebview”:false,“automationName”:“UiAutomator2”,“nativeWebScreenshot”:true,“app”:“https://uipathtestappsto.blob.core.windows.net/testapps/TheApp.apk"},“platformName”:“Android”,“platformVersion”:“11.0”,“deviceName”:“emulator-5554”,“newCommandTimeout”:300,“shouldUseCompactResponses”:false,“elementResponseAttributes”:“rect”,“autoWebview”:false,“automationName”:“UiAutomator2”,“nativeWebScreenshot”:true,“app”:“https://uipathtestappsto.blob.core.windows.net/testapps/TheApp.apk”,“deviceUDID”:“emulator-5554”,“appPackage”:“io.cloudgrey.the_app”}],"alwaysMatch”:{}}}

[WD Proxy] Got response with status 500: {“sessionId”:null,“value”:{“error”:“session not created”,“message”:“io.appium.uiautomator2.common.exceptions.NoSuchDriverException: A session is either terminated or not started”,“stacktrace”:"io.appium.uiautomator2.common.exceptions.SessionNotCreatedException: io.appium.uiautomator2.common.exceptions.NoSuchDriverException: A session is either terminated or not started\n\tat io.appium.uiautomator2.handler.NewSession.safeHandle(NewSession.java:57)\n\tat io.appium.uiautomator2.handler.request.SafeRequestHandler.handle(SafeRequestHandler.java:41)\n\tat io.appium.uiautomator2.server.AppiumServlet.handleRequest(AppiumServlet.java:261)\n\tat io.appium.uiautomator2.server.AppiumServlet.handleHttpRequest(AppiumServlet.java:255)\n\tat io.appium.uiautomator2.http.ServerHandler.channelRead(ServerHandler.java:68)\n\tat io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:366)\n\tat io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerCont…

[W3C] Matched W3C error code ‘session not created’ to SessionNotCreatedError

This is appium version

Here is configuration:

Note: It is working fine with any cloud based emulator saucelabs, Issue with local appium server

I’m not sure, what’s going on. You can also see the device logs issuing adb logcat to see if something helpful is written there. Also downloading the app and manually installing it with adb install .../path_to/app.apk and then starting the app on device to make sure it works on your emulator.

Hello, I am facing an error while starting an application in Uipath mobile Device manager. The error is " A session is either terminated or not started(session not created) ", All components are running and I successfully connected my device to Appium but when I trying to connect using the mobile device manager my Appium automatically disconnect from my device.