Load Python Script: Error loading Python script

All,

I am trying to invoke a Python script from UiPath. It seems that no matter what I try, I run into the error

System.InvalidOperationException, message: “Load Python Script: Error loading Python script”

when trying to use the Load Python Script activity. I have done some digging and tried the solutions available on this site (below)



Needless to say, none of these worked for me. What is stranger, I downloaded files from these threads which claim to successfully execute. Some of these scripts throw the same error I was getting and some do not. See below for projects downloaded from the above threads. I changed any file paths to reflect my local file system before running and ensured that I had dependencies installed (UiPath.Python.Activities). I also have tried installing the available Python packages from the dependency manager, but none resolve the issue.

Completes successfully:
precheck.zip (4.1 KB)

Throws error message:
InvokePython.zip (3.1 KB)

Has anyone encountered this before? Any thoughts on resolutions not mentioned in the above thread?

Thanks in advance,
Michael

Hello, you managed to solve? I am presenting the exact same problem

Type Installing the matching version of Python with target you’ve chose in the python scope activity.
python Windows X86-64 -> python scope taget X64
python Windows X86 -> python scope taget X86

target