Inserting Excel file into Database

Hi guys,
I am try to insert data from a excel spread sheet into a database, the column names in the excel file matches that of the database. now when I try to execute the insert statement upon reading the range, it throws an error "Insert: Missing the DataColumn ‘FirstName’ in the ‘DataTable’ for the SourceColumn ‘FirstName’ ". any ideas on how to fix this issue

try to log the insert statement before the database activity.

I do not follow

sorry instead of the insert statement I used the insert activity

@mb977 You have used Add headers while reading the Excel file right? :sweat_smile:

:joy: Yes I have

@mb977 Check if you have any Spaces in the Column Names of Excel File

I have already included “[ ]” in column names with spaces. am supposing that takes care of the issues that rise because of spaces

@mb977 Show me your Excel File :sweat_smile:


@mb977 Remove and Check

those were not initially there if I remove them, I have a different type of error

@mb977 What is that errror?, You dont need to put that Brackets, it will work without them

it sends an error of "incorrect syntax ‘.’ "

@mb977 Do you need those ‘.’ at the end of Column Name

Yes because the database am trying to insert into has columns names that includes them

@mb977 Then Include Brackets only for those Columns which have ‘.’ and Check

just tried that but the error seems to persist

@mb977 Same Error or Different One?

same syntax error