How to use excel functions in uipath

hi all,

i want to use excel formulas in uipath.
not getting how to use.
can anyone suggest.
like below formulas
LEFT(A1,(FIND(" “,A1,1)-1))
MID(A1,FIND(” ",A1)+1,256)
i tried with write cell “=CONCATENATE(B2,” “,C2)”,but not working :frowning:

Hi @kumari_supriya
You Can Use Write Cell to Insert In the Column the Use Auto fill range Activity to use that formula. You just have to give the Range From where you will get the formula.

1 Like

Hi @kumari_supriya

We can use write cell activity to mention the formula in the excel
— use a excel application scope activity and pass the file path as input
— use write cell activity and mention the value as
“=CONCATENATE(B2,” “,C2)”
— mention the cell position between double quotes

Hope this would help you
Cheers

1 Like

Try using write cell activity inside excel application scope or write cell activity of a workbook.

Hi Palaniyappan,

1.i used within excel application scopeconcatenate

used write cell activity
after running i2 value is showing name
which is not my required value.
kindly help

1 Like

Hi @kumari_supriya

put this in your write cell activity --> “=CONCATENATE(B2,”" “”,C2)"
when we write quotes in write cell we’ve to mention it twice

You were almost done
It should be like this in write cell
=CONCATENATE(B2, “”" "””, C2)

A space next to , and double quotes surrounded by double quotes
#NAME? usually means there are quotation marks missing from a Text argument.

Cheers @kumari_supriya

hi @Palaniyappan

Thanks a lot it worked.
But can you tell me how to use vlookup one in write cell.
i used “=VLOOKUP(A2,EXTRACT_AD_V11_20190621.csv!$B:$C,2,0)” in write cell.
it is not showing the correct result,instead its showing #N/A
Is there any other way to do?
and once we do write cell for 1st cell how to do for whole column means drag.

Thanks for your help.

1 Like

Fine that means your vlookup is correct but there is no value for the condition passed
Kindly check with the condition been applied and the output you want from

For this

Hope this could help you

Kindly Try this and let know for any queries or clarification
Cheers @kumari_supriya

Thanks a lot @Palaniyappan
Now all good.
But It worked fine when i tried to do write range for the whole external workbook sheet to my current excel application scope sheet2 and do vlookup.
is there any other way to do vlookup from external workbook?
and one more query after that i used filter data table activity to filter the data .
but i faced some problem it is not giving the correct data.
i wanted to filter the data on the same column with 2 values.
1st value is showing correct result but not giving result for 2nd values.
attached the screenshot .

result is showing correct for enabled one not for #N/A value.
kindly help me out

Thanks a lot for your help.

1 Like

Great
This one looks good

While for this

I hope the cell with value as #NA will be blank while reading from datatable
So let’s confirm that once
—use a output datatable activity and pass the input as Dt_Unfiltered and Get the output with a variable of type string named out_text
—use a write line activity and pass that out_text activity and check for the value of datatable whether we are getting #NA or some other term for #NA in output panel
—based on that keep the value in the filter wizard condition

You were almost done
Hope this would help you
Kindly try this and let know for any queries or clarification
Cheers @kumari_supriya

@Palaniyappan

Yes you are correct.
When i did the writeline for the data table ,i saw #N/A value is showing as -2146826246.
Hence applied filter now for -2146826246 this value .
so in the output correct rows are displayed now.
But for the user _status column #N/A value are now displayed as -2146826246.

Thanks for your help.

1 Like

Actually
-2146826246 is the code for #N/A
For more details on it kindly have a view on this

We need to check only why this #N/A comes but I hope this comes only when there’s is no match for the look up we have made
So it won’t be an issue I guess
Hope we are going good

Cheers @kumari_supriya

Hi,
Is there a way to concatenate the values through the column names?