How to read binary excel sheet using uipath

Hi Team,

I want to read binary excel sheet,i tried using excel application scope with read range activity.i got sheet not found exception.

Can you please help me here



Share the Excel sheet please? Make sure the sheet name in the excel sheet is same that you have mentioned in the read range activity.


@cheersrpa check sheet name once, if sheet name is correct give space at end of sheet name in read range activity

tried,getting null exception (Object reference not set to an instance of an object.",)

@cheersrpa in default value of datatable New New System.Data.DataTable() and try once if this is not possible share ur excel with sample data and workflow

the data is confidential, i cant share the input file

@cheersrpa try by giving default value to datatable variable as New System.Data.DataTable() and also check whether u have assigned output variable to read range activity and also check read other input and output variables once

My Input file will come in binary format (.xlsb). but bot is unable to read.So my next step is i want to convert this file to .xlsx file using macro or vba code.

Can someone tell me how to get that vba or macro code?


Hi @cheersrpa,

I found this thread:

Following it, I made this small example. Could you give it a try if it works, and then replace my example file with yours? (33.0 KB)


hey @loginerror

thanks for the help…when i run your workflow alone (sample given in above post).i am getting the output.But i tried with my sample doesnot work for me.

i am getting the below error.

message": “Read Range: A column named ‘*’ already belongs to this DataTable”.


This error occur when columns have similar name in excel, Check the columns once

hey @Manjuts90

i checked the column headers …it has unique names only

Could you debug the issue a bit this way:

  1. Make a backup of your file
  2. Remove all columns except for the first one
  3. Try to run in in my example.
  4. If it will work, add more columns, one by one and keep testing until it stops.

We need to be sure whether it is a bug in the activity or something specific to your file :slight_smile: (or maybe both to some extent)

1 Like

hey @loginerror

the above error bcoz of one more hidden row was there with some special charactes(*.",")

now i removed…it worked perfectly.

Thank you soo much :slight_smile:

1 Like