How execute a procedure in UiPath

I’m trying to execute a procedure with parameters but it is returning me this error

What is it? MySQL, SQL, Oracle, etc ?
What is your output variable type?
Did you update the activity to the latest version? Which activity are you using.

from earlier topics: Getting stored procedure output error value is too large to bind

There might not be solution yet, but maybe you can provide more info about your stored procedure and what your output should be

it would be in oracle, there are 4 parameters, there are 3 varchar2 and 1 integer
Yes, the activity pack I am using is up to date.
I took a look on the internet on this subject but I didn’t find anything that worked, I’m already out of ideas :confused:

doesnt seem right that you have "begin " in there, i think it should be just the procedure name in there…

Use EXECUTE NON QUERY a activity and mention the Procedure Name alone
And in the property panel of this activity change the CommandType property as STORED PROCEDURE
And in Parameters property we can pass the IN arguments we have with appropriate type as per the one we have defined in that procedure

For more info on that activity

Cheers @Mths_Teixeira

1 Like

I believe the call method is correct, because I have already made other procedure calls and it worked, the problem is even with the parameters, I think it has something to do with the VARCHAR2 specified in the procedure, it seems that the String type does not support all the characters that VARCHAR2 can pass, do you know if there is another type of string variable that is “larger” or something like that?

thankful little friends

Actually it would accept buddy like string and varchar2 work in sync for any length

Cheers @Mths_Teixeira