Got msg : cannot find the ui element corresponding to this selector

Hi !

I’m facing an issue about the selector. It shows me this :

Message: Cannot find the UI element corresponding to this selector:
Exception Type: UiPath.Core.SelectorNotFoundException

I created a variable that i put in the selector using this tech Add variable in selector


i don’t know how to fix this

Can anyone help me ?

thanks

Looks like you’ve got extra spaces in the id tag at the end, I don’t know if that is intentional? If not, try it like this: id='"+idd+"'

So without spaces between the single and double quotes.

i corrected that : no change :roll_eyes:

Hi @grish,
Try id=’" & idd &"’
It will work.

Okey here try to check the selector using uiExplorer, and remove ID property and add other properties like col/row if you can get or the name something other than Id which will be constant all the time.

hi there !
thanks for the replies. It still doesn’t work. Maybe it’s because the page is dynamic ? what would happen if i remove the title for example or the id = 'ptModFrame_0" ? It would be less accurate ?

hi just a little update :
i rewrite the selector as it was on the picture and finally it worked \o/
i think it’s maybe because of the space between the “/>” and “<” ?

By the way thanks for the help