Global Variables are not declared after reopening the file

Hi,

Studio version: 22.10.4

I am stuck with the problem or actually two problems.

  1. I think there might be some memory access problem with UiPath version 22.10.4, although there is always around 2-4gb of RAM resources, I’ve been getting the 'this operation couldn't be completed due to lack of memory' errors.
  2. After this happens, reopening the project will cause all of the global variable used to be shown as not declared when trying to compile the project.
    It’s a real pain in the ass.

Steps to reproduce:

  1. Declare a global variable.
  2. Use the variable in the workflow
  3. Get 'this operation couldn't be completed due to lack of memory'
  4. Reopen the project.
  5. Try to compile the project.
  6. Error will happen

Steps to fix:

  1. Open workflow with an error.
  2. Click on the activity using the variable.
  3. Repeat for all the errors.

I decided to use global variables in big projects in case of config dict and some other variables which would need to be passed throughout the whole project, however as it is rn the feautre seems unusable. The whole purpose of using it (speeding the development) is being defeated by time I have to spend to open each workflow and check the variables.

Btw I have tried using variables with full namespace, partial namespace or without namespaces, non of this seems to be working.

Please have a look at it.

@GT_Ropa can you please share a sample of a workflow where global variables are not working properly? We had some issues but hopefully, they will be fixed with the incoming 23.2 release.

If you can share a sample workflow we can also validate this scenario.

@alexandru

I have checked but it seems that I didn’t commit before changing from global to normal variable/arguments. The earliest commit is already after the change so I don’t have the workflow.

@alexandru,
I am in the same issue, I declared global variables to use as static variables for supporting to re-call those variable in child-workflow or process in project. It worked perfectly at first time BUT, after reopening the error showing that [Global variable] is not declared.


2 Likes

Nothing for this yet? I’m having the same issues.
What’s weird is the code runs fine, but when I go to publish I get these errors