Get Asset - You are not authenticated! Error Code: 0

Hi All,

Having an issue when trying to use the ‘Get Asset’ activity when in Debug.
I’ve checked the Asset name, I’ve tried changing dependency versions but nothing I am doing is working. I’ve restarted the machine too (just encase)

I’ve checked a different project which is running fine on the same asset and another developer has also tested and they can also obtain the asset.

This is a new project I am working on but seems strange I am not able to get past this error.


Any help would be great!
I’ve seen previous questions like this from a couple years ago and usually it is to do with the System.Activities but I’ve tried quite a few prior versions with no joy.

I’ve also matched all the same dependencies that the other developer is using who is not receiving this error.



Are you connected to the same orchestrator? Also the same asset folder?


Hi @Craig_Bannerman1

Have a look on the thread


Yes checked Assistant and connection is fine, also checked the Folder selected in Studio and it is directing to the required folder.

Hi @Craig_Bannerman1 ,

Could you check if the Studio is connected to the Orchestrator?
Either way you could try Refreshing it like so →


Kind Regards,
Ashwin A.K

Hi Ashwin,

It’s definitely connected



Assets are configured in the orchestrator on the Folder level.
Are you:

  • as a user member of that folder?
  • is the Studio/developer Robot properly linked to you and licensed? (I assume yes, looking at your connected status)

@Jeroen_van_Loon - Yes I am a user who has access to assets, the robot role also has access to the assets with read and write permissions

can you check if trim is helping
asset name: row(“Asset”).toString.Trim

@ppr unfortunately not.
I’ve tested without using the Config as well with no joy.

I’d share a screenshot of the asset name and config but it contains a client name so can’t share it

But assetname is not containing any spaces or special characters like letters with accesnts, right?

For an analysis round we would recommend to isolate the issue by only single test activity - right click on get orchestrator asset activity (left, activities panel) and select create test bench

then do a testing with hardcoded asset name. Once this is working you can continue with the issue analysis within your modelling. Isolated tests will save us time, as we will have less to wait till reaching the part of interest

I’ve done an isolated test as advised. - Still the same error

That is using the below dependencies which I suspect may be an issue:

But more annoyingly if I go to an older project and attempt to get that same asset:

The project that works uses these dependencies - but they are preview so I cannot upgrade / downgrade to them:

we would rely on all your information / screenshots and it looks that the connections, permissions and feed selection is valid.

Now it is time to focus on Package version checks. Herefore create a new project, use the isolated test case (ensure again the right folder feed selection) and decrease iterative the relevant package versions.

So I created a new project and re-ran the Test Bench to get the same asset which was successful.

It used the following dependencies:

So I then downgraded my current project to these same versions… and yet the same error still occurs


when we had proven isolated that a package version and its acitvity is working fine, but the same construct is broken when touching package versions, then we delete the failing activity and do remodel it.

In your case: ensure correct working package version is configured, then drag and drop the get ORC Asset activity, transfer the setting and delete the old failing one. Give a try on this

@ppr - Sorry same error still occuring

here you need to track all differences between the different RnDs and Projects. This will take some time and also requires concentrated work.

Ensure that once a working combination (Package version / activity) is found, this is transferred to your current project freshly.

You will beat the issue :+1:


not sure if an explicit reference to UiPath.Activities.Api is needed. Check its removal also


Good guess!

Removed the UiPath.Activities.Api and now it’s back and functional!
Must have added that by accident when adding the package for the WebApi.

Thanks for your help @ppr :slight_smile:

That was an unexpected resolution!

Don’t forget to mark ppr’s answer as solution so that others facing similar issues may benefit from it,and also so that we may close this thread.

Kind Regards,
Ashwin A.K

1 Like