For Each UI Element doesn't save

I’m inside a Use Application/Browser, I add the For Each UI Element, I add an element and everything works correctly. I click Save & Close and then nothing is saved in the activity. All the properties are still empty.

I had similar issue twice - you can try to delete and insert the same activity. Check if it will help you.

Please check the following things:

  • Ensure that you have the latest version of the UiPath—UIAutomation package installed in your project. Sometimes, updating the package can resolve issues with activities not saving their properties.
  • Close and reopen UiPath Studio to ensure that there are no temporary issues causing the properties not to save.
  • In rare cases, a workflow file may become corrupted. If the issue persists, consider creating a new workflow and copying the activities from the problematic workflow to the new one.

Just tried to use a For Each UI Element and the same is happening. UiPath.UIAutomation.Activities 23.4.8 and System 23.4.4.

Hey UiPath, any attention being paid to this problem?


I just tried to use Extract Table Data and it’s doing the same thing. After completing the wizard there is no target defined.

Any chance you can provide a few screenshots of the expected misbehavior? I struggle a bit to reproduce this.

Here is an example:

Clearly the selector, metadata, etc are filled in.

But when I click Edit Extract I get…


And when I test it, it just sits for a while, and if I cancel it:


Yet it very clearly has a value.