Expression activity type 'CSharpValue`1' requires compilation inorder to run

Hi. I’m using UiPath studio 2021.10.3 community license. I created a new project with cross-platform compatibility and language as C#. I created a small sequence with first step as read workbook range activity, second step as write line activity.

I set breakpoint at write line activity. Now I’m debugging project. Bot stopped at breakpoint.

Now in the immediate panel, when I try to execute any commands, I’m getting following error:
“Expression activity type ‘CSharpValue`1’ requires compilation inorder to run. Please ensure that workflow has been compiled”

Can you please guide me how to resolve this error?

From what I learned this happens when you copy activities from a C# workflow into a VB workflow (and perhaps vice versa). Could it be possible that in your case there is a mismatch in programming languages as well? Can you maybe check the project.json file and make sure the expressionLanguage is really set to CSharp?

Hi friends,
I have received same error message while using http request, I have checked my project.json file, and the language type was correct, my preview for the http request returns statues 200, however, same error shows us as type “VisualBasicValue1” requires compilation in order to run.

Possible solution:

We just upgraded to Studio ver. 22.10.3 including Orchestrator and robots. We upgraded a few processes so that they no longer uses “Windows-legacy”.

What we learned from this was that all components and processes that use UiPath.System.Activities ver 22.10.3 now work fine after the upgrade.

To conclude: update by using UiPath.System.Activities ver 22.10.3.

Hi @jardar.nesse - Even I am facing same issue and I am currently using 10.3 version only. BUt still same error

So how do you solve this problem later?